How can I install xml development headers (version 2.9.1) and xz development headers(version 5.1.1) using ***sudo apt-get*** ?
1
0
Entering edit mode
3.9 years ago
jth6974 ▴ 10

Hello. To install antiSMASH in Debian Linux 8, I have installed following dependencies except two of them.

First, make sure you have the following antiSMASH dependencies installed:

  1. diamond (version 0.8.36 tested)
  2. fasttree (version 2.1.7 tested)
  3. glimmer (version 3.02 tested)
  4. GlimmerHMM (version 3.0.4 tested)
  5. hmmer2 (version 2.3.2 tested, append a 2 to all hmmer2 executables to avoid conflict with hmmer3 executable names, like hmmalign -> hmmalign2)
  6. hmmer3 (3.1b2 tested)
  7. mafft (version 7.271 tested)
  8. meme (version 4.11.2 tested. Version 4.11.4 changes output file formats, so don't use that.)
  9. muscle (version 3.8.31 tested)
  10. NCBI blast+ (version 2.2.31 tested)
  11. prodigal (version 2.6.1 tested)
  12. xml development headers (version 2.9.1 tested)
  13. xz development headers (version 5.1.1 tested)
  14. python (version 2.7.9 tested, any python 2.x >= python 2.6 should work)
  15. python-virtualenv (not needed, but highly recommended)

what I didn't install is 12 and 13. I don't understand what xml development headers means? so here are my question.

How can I install xml development headers (version 2.9.1) using sudo apt-get ? (if there is no way for install using sudo apt-get, where can I download it?)

antismash xml • 1.3k views
ADD COMMENT
2
Entering edit mode
3.9 years ago

xml development header

should be https://askubuntu.com/questions/733169

sudo apt-get install libxml2-dev

ADD COMMENT
0
Entering edit mode

thanks a lot ! one more question ! how can I check which version of xml has been installed ?

ADD REPLY
0
Entering edit mode
xml2-config --version
2.9.3
ADD REPLY
0
Entering edit mode

xz development headers (version 5.1.1 tested)

In doubt, you can also query the APT cache for package descriptions.

$ apt search xz development files
Sorting... Done
Full Text Search... Done
devscripts/stable,now 2.17.6+deb9u1 amd64 [installed]
  scripts to make the life of a Debian Package maintainer easier

libarchive-dev/stable 3.2.2-2 amd64
  Multi-format archive and compression library (development files)

liblzma-dev/stable,now 5.2.2-1.2+b1 amd64 [installed]
  XZ-format compression library - development files

So you need sudo apt install liblzma-dev for the XZ development headers.

And if you do not remember which version you installed: dpkg -l liblzma-dev.

ADD REPLY

Login before adding your answer.

Traffic: 1722 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6