Question: meet "not enough memory" problem during SOAPdenovo assembly
1
gravatar for Yingzi Zhang
5 months ago by
Yingzi Zhang50
Beijing
Yingzi Zhang50 wrote:

Hey guys, I am doing de novo assembly. The data is downloaded from NCBI and they are DNA-seq short paired-end reads, 100bp x 2, about 120G in total. I use SOAPdenovo to assembly them. The k-mer value was set 29. After 10 hours, the server reported like this:

Ran out of memory while applying 13290854152bytes
There may be errors as follows:
1) Not enough memory.
2) The ARRAY may be overrode.
3) The wild pointers.

It was done on a server with 768G RAM and 50T internal storage. I don't know why it ran out of memory while applying 13G data, could anyone explain a little bit? There was no other tasks during the assembly.

Thank you.

assembly genome • 336 views
ADD COMMENTlink modified 5 months ago by b.nota5.4k • written 5 months ago by Yingzi Zhang50

Hello,

could you please provide the command you use?

fin swimmer

ADD REPLYlink written 5 months ago by finswimmer7.9k

Not enough memory is probably referring to RAM, not internal storage. How much RAM does the server has?

ADD REPLYlink written 5 months ago by b.nota5.4k

yes... I misunderstood the concepts. sorry for the mistake. The server's RAM is 768G, with a 50T internal storage.

ADD REPLYlink written 5 months ago by Yingzi Zhang50

yes, it's:

SOAPdenovo-127mer all -s ./config_file -K 29 -p 20 -R -o graph_prefix 1 > ass.log 2 > ass.err
ADD REPLYlink modified 5 months ago by genomax59k • written 5 months ago by Yingzi Zhang50

Please use the formatting bar (especially the code option) to present your post better. I've done it for you this time.
code_formatting

Thank you!

ADD REPLYlink written 5 months ago by genomax59k

copy that. thank you

ADD REPLYlink written 5 months ago by Yingzi Zhang50
2
gravatar for b.nota
5 months ago by
b.nota5.4k
Netherlands
b.nota5.4k wrote:

Did you use the latest version? There was a bug giving the same error in previous versions, see here, they seem to have fixed it in newer versions.

ADD COMMENTlink written 5 months ago by b.nota5.4k

yes, i changed to the latest version and it worked. thank you very much!

ADD REPLYlink written 5 months ago by Yingzi Zhang50

Hello Yingzi,

If an answer was helpful, you should upvote it; if the answer resolved your question, you should mark it as accepted.

Upvote|Bookmark|Accept

ADD REPLYlink modified 5 months ago • written 5 months ago by finswimmer7.9k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1809 users visited in the last hour