Question: StringTie missing header
0
gravatar for SarRo
10 months ago by
SarRo0
SarRo0 wrote:

Hi,

I am a newbie to RNA seq and differential gene expression and I'm struggling with stringtie.

After merging all my stringtie outputs into a reference .gtf I've got same error messages for every sample.

samopen] no @SQ lines in the header.
[sam_read1] missing header? Abort!

I've used the following command:

stringtie -e -B -p 4 -G /merged_gtf_location/stringie_merged.gtf -o stringtie_out.gtf sample1.gtf --rf

When I converted my hisat2 outputs into .bam files I checked for headers and also running stringtie the first time didn't give me that error. I guess it's just a very stupid mistake but I really can't figure it out on my own and I'd be really happy for any help.

rna-seq assembly • 409 views
ADD COMMENTlink modified 10 months ago by lakhujanivijay4.7k • written 10 months ago by SarRo0

Apparently I didn't. Wow, that's embarrassing! I've checked my command so many times and it really didn't occur to me... Thank you!

ADD REPLYlink written 10 months ago by SarRo0

If an answer was helpful, you should upvote it; if the answer resolved your question, you should mark it as accepted. You can accept more than one if they work.
Upvote|Bookmark|Accept

ADD REPLYlink written 10 months ago by genomax76k
3
gravatar for swbarnes2
10 months ago by
swbarnes27.2k
United States
swbarnes27.2k wrote:

Umm, where in that command line are you telling StringTie where your bam is?

ADD COMMENTlink written 10 months ago by swbarnes27.2k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2016 users visited in the last hour