Question: using trimmomatic software
0
gravatar for haddadfatiha62
18 months ago by
haddadfatiha620 wrote:

Hi I m begening at bioinformatic ,i want use trimmomatic for trimming my data , i install trimmomatic by conda , and i use this command

trimmomatic PE -phred33 ERR770964_1.fastq ERR770964_2.fastq paired_1_R1_paired.fq.gz unpaired_1_R1_unpaired.fq.gz paired_1_R2_paired.fq.gz unpaired_1_R2_unpaired.fq.gz ILLUMINACLIP:TruSeq3-PE.fa:2:30:10 LEADING:3 TRAILING:3 SLIDINGWINDOW:4:15 MIN

i get 4output paired and un paired (reverse and forward) but i also get this message, i didn't know if my trimming is correct or no ,how I can verify my trimming??

TrimmomaticPE: Started with arguments:
 -phred33 ERR770964_1.fastq ERR770964_2.fastq paired_1_R1_paired.fq.gz unpaired_1_R1_unpaired.fq.gz paired_1_R2_paired.fq.gz unpaired_1_R2_unpaired.fq.gz ILLUMINACLIP:TruSeq3-PE.fa:2:30:10 LEADING:3 TRAILING:3 SLIDINGWINDOW:4:15 MINLEN:3
java.io.FileNotFoundException: /data/f.haddad/analyses/TruSeq3-PE.fa (No such file or directory)
        at java.base/java.io.FileInputStream.open0(Native Method)
        at java.base/java.io.FileInputStream.open(FileInputStream.java:219)
        at java.base/java.io.FileInputStream.<init>(FileInputStream.java:157)
        at org.usadellab.trimmomatic.fasta.FastaParser.parse(FastaParser.java:54)
        at org.usadellab.trimmomatic.trim.IlluminaClippingTrimmer.loadSequences(IlluminaClippingTrimmer.java:110)
        at org.usadellab.trimmomatic.trim.IlluminaClippingTrimmer.makeIlluminaClippingTrimmer(IlluminaClippingTrimmer.java:71)
        at org.usadellab.trimmomatic.trim.TrimmerFactory.makeTrimmer(TrimmerFactory.java:32)
        at org.usadellab.trimmomatic.Trimmomatic.createTrimmers(Trimmomatic.java:59)
        at org.usadellab.trimmomatic.TrimmomaticPE.run(TrimmomaticPE.java:552)
        at org.usadellab.trimmomatic.Trimmomatic.main(Trimmomatic.java:80)
Input Read Pairs: 1151860 Both Surviving: 1143620 (99.28%) Forward Only Surviving: 8157 (0.71%) Reverse Only Surviving: 75 (0.01%) Dropped: 8 (0.00%)TrimmomaticPE: Completed successfully

can you help me please

software error • 509 views
ADD COMMENTlink modified 18 months ago • written 18 months ago by haddadfatiha620
FileNotFoundException: /data/f.haddad/analyses/TruSeq3-PE.fa (No such file or directory)

Doesn't that suggest that something didn't work correctly? Are you absolutely sure that there is a file by that name in that location?

ADD REPLYlink written 18 months ago by swbarnes29.2k

hi haddadfatiha62 ,

I added (code) markup to your post for increased readability. You can do this by selecting the text and clicking the 101010 button. When you compose or edit a post that button is in your toolbar, see image below:

101010 Button

ADD REPLYlink modified 18 months ago • written 18 months ago by lieven.sterck9.0k
0
gravatar for theglobetrotter78
18 months ago by
theglobetrotter7850 wrote:

Its not finding the adapter sequence file TruSeq3-PE.fa. Adapter sequence files are in the adapters folder within the Trimmomatic folder. You should provide the correct path to that adapter .fa file in your command as shown below.

ILLUMINACLIP: path to your trimmomatic folder/adapters/TruSeq3-PE.fa

ADD COMMENTlink modified 18 months ago • written 18 months ago by theglobetrotter7850
0
gravatar for haddadfatiha62
18 months ago by
haddadfatiha620 wrote:

yes you are right Ihave a problem in the path of the directory thanks you so much for your help

ADD COMMENTlink modified 18 months ago • written 18 months ago by haddadfatiha620
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1490 users visited in the last hour