PROVEAN not working
3
1
Entering edit mode
16 months ago
AnnaW ▴ 20

Hello All,

I'm having troubles making PROVEAN work.

I’m getting this error while trying to run PROVEAN

Protein database:

/gpfs01/home/x/NCBI-BLAST/blastdb/ftp.ncbi.nih.gov/blast/db/nr

[17:44:08] searching related sequences...

[18:45:32] clustering subject sequences... ./provean.sh: line 187: 41879 Segmentation fault $COMMAND

Any idea what I'm doing wrong?

provean • 1.1k views
ADD COMMENT
0
Entering edit mode

Segfaults are usually an out-of-memory issue.

How big is your dataset, how much RAM do you have available? Does the command complete successfully for minimal, or even single input data?

ADD REPLY
0
Entering edit mode

I am having the same problem here testing on the sample data. Using top, I find that Provean is not using a 10th of my available RAM, so there must be something else wrong. Do the developers of Provean have a way to raise issues with them? I can't find any details for raising an issue online.

ADD REPLY
0
Entering edit mode

There's a web contact form: http://provean.jcvi.org/contact.php

I'd try that first, but I wouldn't expect a speedy reply.

ADD REPLY
0
Entering edit mode

Ya I tried all those links. None of the emails work. The email I sent were not delivered. The online form you referenced did not work as well.

ADD REPLY
0
Entering edit mode

Hi, did you find solution for this?

ADD REPLY
1
Entering edit mode
15 months ago
AnnaW ▴ 20

I ended up using PROVEAN web interface.

It seems that this segmentation fault is a common problem. I've tried using a big memory machine (500GB) but the error was still appearing. Similarly, I've tried installation via conda as well. I ended up with the same error

ADD COMMENT
0
Entering edit mode
8 months ago

You can try using the following versions: - BLAST+ v2.4: https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/2.4.0/ - NR: ftp://ftp.jcvi.org/pub/data/provean/nr_Aug_2011/ It works for me.

ADD COMMENT
0
Entering edit mode

Hi, do you have a backup of this nr database? I tried this link but it does not work.

ADD REPLY
0
Entering edit mode
6 weeks ago
YuFeng • 0

The blast+ v2.4.0 and nr database version4 from https://ftp.ncbi.nlm.nih.gov/blast/db/v4/ works. It seems that provean does not compatible with the latest blast database (version 5).

ADD COMMENT
0
Entering edit mode

Hi YuFeng, I have some issue with V4 db download. Could you please let me know how you did it, I saw you have similar question before, but you fixed. Thnaks,

 Perl path/ncbi-blast-2.4.0+/bin/update_blastdb.pl --passive --decompress nr

Can't locate Archive/Tar.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /home/gaom4/proVean/ncbi-blast-2.4.0+/bin/update_blastdb.pl line 42.
ADD REPLY
0
Entering edit mode

HI guys, I am working on proVean this week, and met all the issued people posted online. Main problems I think are elated to the versions for blast, db and cd-hit since all three get updated but probbaly not apply properly for proVean. I will going to try V4 version, as Yufeng mentioned this morning, but met new issues again.

If anyone can give me some solutions, will save me life. ...lol...

ADD REPLY
0
Entering edit mode

I just downloaded all tarballs from https://ftp.ncbi.nlm.nih.gov/blast/db/v4/ (nr_v4.*.tar.gz) and unzipped them (using command tar zxvf ), and it works.

ADD REPLY

Login before adding your answer.

Traffic: 2935 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6