Question: Stacks 1.44 Error
0
gravatar for virtualinterlect
12 days ago by
virtualinterlect0 wrote:

Hi,

I installed stacks using conda, and stacks 1.44 was installed. However, I would have loved to have the recent version 2.53 at least.

I decided to run denovo.pl on the version 1.44 and the error message I got was

Unknown command line option: '--popmap'

My command is

denovo_map.pl --samples /public/home/WHC_BBT/Substacks21/ \
              --popmap /public/home/WHC_BBT/Substacks21/popu-sub.txt \
              -o /public/home/WHC_BBT/Substacks21/M3/ \
              -M 3\
              -n 3 \
              -X "populations: -r 0.8 -T 10" \
              --paired

How can I overcome this?

Do I need to remove 1.44 and install 2.53 directly instead of using conda?

ddrad stacks rad-seq • 63 views
ADD COMMENTlink modified 12 days ago by h.mon32k • written 12 days ago by virtualinterlect0

Please use the formatting bar (especially the code option) to present your post better. You can use backticks for inline code (`text` becomes text), or select a chunk of text and use the highlighted button to format it as a code block. If your code has long lines with a single command, break those lines into multiple lines with proper escape sequences so they're easier to read and still run when copy-pasted. I've done it for you this time.
code_formatting

ADD REPLYlink written 12 days ago by Ram32k
0
gravatar for h.mon
12 days ago by
h.mon32k
Brazil
h.mon32k wrote:

Bioconda has a recipe for Stacks 2.53, it is unclear how you ended up with version 1.44.Install Stacks in a new conda environment:

conda create -n Stacks-2.53
conda activate Stacks-2.53
conda install Stacks=2.53  -c bioconda
ADD COMMENTlink modified 9 days ago • written 12 days ago by h.mon32k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1249 users visited in the last hour
_