Looking for incompatible packages
0
0
Entering edit mode
7 weeks ago
Юлия ▴ 10

enter image description here

I have problems while installing a tool from .yaml file:

Collecting package metadata (repodata.json): done

Solving environment: | 
Found conflicts! Looking for incompatible packages.

This can take several minutes.  Press CTRL-C to abort.

Examining conflict for 
statsmodels psutil xopen certifi kiwisolver future drmaa tinycss2 pip patsy scikit-learn scipy bz2file python_abi pillow wheel python-isal svglib threadpoolctl tesorter libgcc libwebp-base graphite2 libglib r-lattice hmmer xorg-libsm r-matrix pixman harfbuzz cairo pillow python-isal gst-plugins-base perl-params-validate r-digest

At the end I got a bunch of different errors.... I created a new environment first, then tried to install as I mentioned above. Why does it occur?

conda • 219 views
ADD COMMENT
1
Entering edit mode

Is this a single tool? Try to install that separately, like conda install -c <channel> <tool>. Having yaml files that include precise versions for many dependencies can be difficult, let conda solve that all and give only the tools you want.

ADD REPLY
0
Entering edit mode

In addition, try using mamba instead of conda.

ADD REPLY

Login before adding your answer.

Traffic: 1439 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6