Question: I am trying to load a BAM file (Whole Genome) to IGV but I can't see anything
0
gravatar for santi.ha92
2.4 years ago by
santi.ha920
santi.ha920 wrote:

Hi, I'm working with a de novo genome assembly and I want to view the read alignments in IGV. I have already sorted and indexed (.bam and .bai) the reads, but when try to view them in IGV nothing happens.

as-munoz:~ andrewcrawford$ /Users/andrewcrawford/Instaladores/samtools-0.1.19/samtools view -h /Volumes/Biomics_Transcriptomics/Datos_Tesis_Santiago_Herrera/Dovetail/bams/chicagoLibrary1.a.lines.snap.md.sorted.bam | head -30

@HD VN:1.4  SO:coordinate
@RG ID:FASTQ    PL:Illumina PU:pu   LB:lb   SM:sm
@PG ID:SNAP PN:SNAP CL:paired /mnt/projects/capybara/results/a.lines/snap_index_16 merged_r1.fq.gz merged_r2.fq.gz -t 16 -o -bam aln/capybara.CP1786.snap.md.sorted.bamtmp.bam -ku -as -C-+ -tj GATCGATC -mrl 20 -pf analysis/alignment_stats.txt   VN:1.0dev.67_as
@SQ SN:flattened_line_0 LN:1915822
@SQ SN:flattened_line_2 LN:1534219
@SQ SN:flattened_line_4 LN:1469672
@SQ SN:flattened_line_6 LN:1370607
@SQ SN:flattened_line_8 LN:1283437
@SQ SN:flattened_line_10    LN:1278185
@SQ SN:flattened_line_12    LN:1243555
@SQ SN:flattened_line_14    LN:1221447
@SQ SN:flattened_line_16    LN:1204894
@SQ SN:flattened_line_18    LN:1187301
@SQ SN:flattened_line_20    LN:1170803
@SQ SN:flattened_line_22    LN:1147142
@SQ SN:flattened_line_24    LN:1127848
@SQ SN:flattened_line_26    LN:1116213
@SQ SN:flattened_line_28    LN:1097203
@SQ SN:flattened_line_30    LN:1084106
@SQ SN:flattened_line_32    LN:1078477
@SQ SN:flattened_line_34    LN:1066228
@SQ SN:flattened_line_36    LN:1062702
@SQ SN:flattened_line_38    LN:1062595
@SQ SN:flattened_line_40    LN:1047902
@SQ SN:flattened_line_42    LN:1050310
@SQ SN:flattened_line_44    LN:1045527
@SQ SN:flattened_line_46    LN:1024540
@SQ SN:flattened_line_48    LN:1021804
@SQ SN:flattened_line_50    LN:1020795
@SQ SN:flattened_line_52    LN:1017325

I really appreciate any help,

best,

Santiago

next-gen alignment genome • 1.3k views
ADD COMMENTlink modified 2.4 years ago by geek_y9.1k • written 2.4 years ago by santi.ha920
2

hi, Maybe confirm that the chromosome names match in your BAM with those in the "Genome" you have selected in IGV. From what your samtools view says, the chromosome (contig) names are like flattened_line_xx.

ADD REPLYlink written 2.4 years ago by Amitm1.6k
2

What does "nothing happens" mean? You probably have to zoom in more.

ADD REPLYlink written 2.4 years ago by Devon Ryan88k

I agree with @Devon. If you are sure that you have accurately created a genome file for IGV, then you probably just need to zoom in.

ADD REPLYlink written 2.4 years ago by Satyajeet Khare1.3k

Are you sure you have the correct reference genome? It must be the same used for mapping.

ADD REPLYlink modified 2.4 years ago • written 2.4 years ago by Gabriel R.2.5k

Can you provide a screenshot from IGV ?

ADD REPLYlink written 2.4 years ago by geek_y9.1k

Also have to select a chromosome from the dropdown list otherwise nothing appears

ADD REPLYlink written 2.4 years ago by microfuge970

If it is a denovo genome assembly, what alignments are you trying to look at?

ADD REPLYlink modified 2.4 years ago • written 2.4 years ago by Zaag670

Have you tried zooming in or select any chromosomes and try zooming it

ADD REPLYlink written 2.4 years ago by bioinforesearchquestions200
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 2484 users visited in the last hour