Question: Install Lefse in Ubuntu 12
0
gravatar for goh
20 months ago by
goh10
goh10 wrote:

Hi all,

I'm new to bioinformatics and command/ scripts.

I have been trying to install lefse in ubuntu 12 which i build in virtualbox, but unsuccessful.

I have found and followed one instructions as below. https://bitbucket.org/nsegata/metaphlan/wiki/MetaPhlAn_Pipelines_Tutorial

However, still couldn't manage to get the package installed. Do i need to execute other scripts or install other packages besides the one listed required by lefse to run ?

Does anyone faced similar problems before?

Thanks.

Regards, Goh.

install lefse microbiome • 1.2k views
ADD COMMENTlink written 20 months ago by goh10

Any reason you installed Ubuntu 12? That's 6 years old...

However, still couldn't manage to get the package installed.

Does anyone faced similar problems before?

Please elaborate on error messages/output/reason why you believe the package is not installed. We cannot see what happens on your computer so you'll have to be more precise.

ADD REPLYlink written 20 months ago by WouterDeCoster43k

i have successfully installed pip and matplotlib using the command as below.

sudo apt-get python-pip
sudo apt-get python-matplotlib

When i execute the command below i have these errors

 sudo pip install https://bitbucket.org/nsegata/lefse/get/default.zip
Downloading/unpacking https://bitbucket.org/nsegata/lefse/get/default.zip
  Downloading default.zip (61Kb): 61Kb downloaded
  Running setup.py egg_info for package from https://bitbucket.org/nsegata/lefse/get/default.zip
    Traceback (most recent call last):
      File "<string>", line 14, in <module>
    IOError: [Errno 2] No such file or directory: '/tmp/pip-ZPkYIX-build/setup.py'
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 14, in <module>

IOError: [Errno 2] No such file or directory: '/tmp/pip-ZPkYIX-build/setup.py'

----------------------------------------
Command python setup.py egg_info failed with error code 1

Fyi, i have just installed ubuntu 12 in virtual box and im using windows. Could you please advice ?

Thanks. Goh.

ADD REPLYlink modified 20 months ago by genomax78k • written 20 months ago by goh10

Try to :

pip install --upgrade pip

From here and there

And retry your python setup

ADD REPLYlink modified 20 months ago • written 20 months ago by Bastien Hervé4.5k

Hi,

Do you mean the Ubuntu setup from the begining?

Regards, Goh

ADD REPLYlink written 20 months ago by goh10

No, do :

pip install --upgrade pip
sudo pip install https://bitbucket.org/nsegata/lefse/get/default.zip
ADD REPLYlink written 20 months ago by Bastien Hervé4.5k

Hi, pip install --upgrade pip resulted some error as below. Btw, im now using ubuntu 14.

luc@luc-VirtualBox:~$ pip install --upgrade pip
Downloading/unpacking pip from https://files.pythonhosted.org/packages/0f/74/ecd13431bcc456ed390b44c8a6e917c1820365cbebcb6a8974d1cd045ab4/pip-10.0.1-py2.py3-none-any.whl#sha256=717cdffb2833be8409433a93746744b59505f42146e8d37de6c62b430e25d6d7
  Downloading pip-10.0.1-py2.py3-none-any.whl (1.3MB): 1.3MB downloaded
Installing collected packages: pip
  Found existing installation: pip 1.5.4
    Not uninstalling pip at /usr/lib/python2.7/dist-packages, owned by OS
  Can't roll back pip; was not uninstalled
Cleaning up...
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 283, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1436, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 672, in install
    self.move_wheel_files(self.source_dir, root=root)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 902, in move_wheel_files
    pycompile=self.pycompile,
  File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 206, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 193, in clobber
    os.makedirs(destsubdir)
  File "/usr/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/pip-10.0.1.dist-info'
ADD REPLYlink modified 20 months ago by genomax78k • written 20 months ago by goh10
1

Btw, im now using ubuntu 14.

Interesting step forward. Only a couple more version to go and you are current.

ADD REPLYlink written 20 months ago by WouterDeCoster43k

Hello goh ,

Please use the formatting bar (especially the code option) to present your post better. I've done it for you this time.
code_formatting

Thank you!

ADD REPLYlink written 20 months ago by genomax78k

goh : Try adding sudo before your upgrade command.

ADD REPLYlink modified 20 months ago • written 20 months ago by genomax78k

But... why 14 ?

Also, this "error" is well known over the web, just try to google your program name + your error like pip install [Errno 13] Permission denied.

First link

First answer -> Have you tried with sudo?

ADD REPLYlink modified 20 months ago • written 20 months ago by Bastien Hervé4.5k

Hi i tried two command:-

sudo pip install https://bitbucket.org/nsegata/lefse/get/default.zip
sudo -H pip install https://bitbucket.org/nsegata/lefse/get/default.zip

Both failed with error msg,

Could not install packages due to an environment error

Than i downloaded the zip file an unzipped. Trying to install from local. Using the command below:-

sudo -H pip install 'myfilepath/lefse.py'

The error said invalid requirement:  'myfilepath/lefse.py'
It looks like a path. It does exist.

~ Tried the fix as suggested previous post

there is no such file or directory

Any idea ? Thanks.

I'm using ubuntu 16, and probably gonna use it for some time as i did not see any 32bit desktop iso file in 17 n 18.

ADD REPLYlink modified 20 months ago • written 20 months ago by goh10

The two commands were :

sudo pip install --upgrade pip
sudo pip install https://bitbucket.org/nsegata/lefse/get/default.zip

Did you do the first one ?

If you got this error :

Could not install packages due to an EnvironmentError:

[Errno 13] Permission denied:

The important information is [Errno 13] Permission denied:

Why select a 32bits version ? The only reason I found to take a 32bits version is that a software required it.

ADD REPLYlink modified 20 months ago • written 20 months ago by Bastien Hervé4.5k

Hi,

Because I read some where that LEfSe scripts require python2, and rpy2 to communicate with R, but the newest releases of rpy2 no longer support python2 - only python3.

As I'm very new in this, so I choose the earliest Ubuntu version. Because I think python version comes with the Ubuntu installation together. Please correct me if I'm wrong. Thanks.

Goh.

ADD REPLYlink written 20 months ago by goh10

You can set up the python version you want on the Ubuntu version you want, python version is not correlated with Ubuntu version. I think you missunderstood with the ubuntu repo.

You can also setup two different versions of python on the same Ubuntu (like python 2.7 and 3.5 on Ubuntu 16.04, what I have).

In rpy2 requirements you can get :

Python -> 3.5, with intended compatibility with 2.7 and >3.3

IMO, install Ubuntu 16.04 with python 2.7 and that will be OK

ADD REPLYlink modified 20 months ago • written 20 months ago by Bastien Hervé4.5k

Prerequisites for your program are here : https://bitbucket.org/nsegata/metaphlan/overview

  • MetaPhlAn requires python 2.7 or higher with argparse, tempfile and numpy libraries installed (apart for numpy they are usually installed together with the python distribution). Python3 is not supported yet.

  • If you provide the output of BLASTN or BowTie2 as input, there are no additional prerequisite.

  • If you would like to use the integrated BLASTN in MetaPhlAn, you need to have: blastn from the NCBI BLAST+ package version 2.2.25 or higher (blastn needs to be in the system path)

  • If you would like to use the BowTie2 integrated in MetaPhlAn, you need to have: BowTie2 version 2.0.0 or higher and perl (bowtie2 needs to be in the system path with execute _and_ read permission)

ADD REPLYlink modified 20 months ago • written 20 months ago by Bastien Hervé4.5k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 1812 users visited in the last hour