Question: Problem installing DESeq2 in R4.0 linux16.04
0
gravatar for matiasbmg
5 months ago by
matiasbmg0
matiasbmg0 wrote:

I did

if (!requireNamespace("BiocManager", quietly = TRUE))
install.packages("BiocManager")
BiocManager::install("DESeq")

I received this

 Bioconductor version 3.11 (BiocManager 1.30.10), R 4.0.0 (2020-04-24)
Installing package(s) 'DESeq'
also installing the dependency ‘geneplotter’

trying URL 'https://bioconductor.org/packages/3.11/bioc/src/contrib/geneplotter_1.66.0.tar.gz'
Content type 'application/x-gzip' length 1430836 bytes (1.4 MB)
==================================================
downloaded 1.4 MB

trying URL 'https://bioconductor.org/packages/3.11/bioc/src/contrib/DESeq_1.39.0.tar.gz'
Content type 'application/x-gzip' length 1692143 bytes (1.6 MB)
==================================================
downloaded 1.6 MB

* installing *source* package ‘geneplotter’ ...
** using staged installation
** R
** data
** inst
** byte-compile and prepare package for lazy loading
Error: package or namespace load failed for ‘AnnotationDbi’:
 package ‘AnnotationDbi’ was installed before R 4.0.0: please re-install it
Error: package ‘AnnotationDbi’ could not be loaded
Execution halted
ERROR: lazy loading failed for package ‘geneplotter’
* removing ‘/home/uciel/R/x86_64-pc-linux-gnu-library/4.0/geneplotter’
ERROR: dependency ‘geneplotter’ is not available for package ‘DESeq’
* removing ‘/home/uciel/R/x86_64-pc-linux-gnu-library/4.0/DESeq’

The downloaded source packages are in
    ‘/tmp/RtmpMfSFI0/downloaded_packages’
Old packages: 'affyQCReport', 'annotate', 'AnnotationDbi', 'caTools', 'edgeR',
  'genefilter', 'GenomeInfoDb', 'GenomicRanges', 'hgu95av2cdf', 'hgu95av2.db',
  'latticeExtra', 'org.Hs.eg.db', 'simpleaffy'
Update all/some/none? [a/s/n]:

Then i try to update all, but I have a lot of errors like the next and 15 warnings:

* installing *source* package ‘AnnotationDbi’ ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘DBI’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘AnnotationDbi’
* removing ‘/usr/local/lib/R/site-library/AnnotationDbi’
* restoring previous ‘/usr/local/lib/R/site-library/AnnotationDbi’
* installing *source* package ‘caTools’ ...
** package ‘caTools’ successfully unpacked and MD5 sums checked
** using staged installation
** libs
g++ -std=gnu++11 -I"/usr/share/R/include" -DNDEBUG      -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g  -c Gif2R.cpp -o Gif2R.o
g++ -std=gnu++11 -I"/usr/share/R/include" -DNDEBUG      -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g  -c GifTools.cpp -o GifTools.o
gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG      -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g  -c caTools_init.c -o caTools_init.o
gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG      -fpic  -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g  -c runfunc.c -o runfunc.o
g++ -std=gnu++11 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o caTools.so Gif2R.o GifTools.o caTools_init.o runfunc.o -L/usr/lib/R/lib -lR
installing to /usr/local/lib/R/site-library/00LOCK-caTools/00new/caTools/libs
** R
** byte-compile and prepare package for lazy loading
Error: package ‘bitops’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘caTools’
* removing ‘/usr/local/lib/R/site-library/caTools’
* restoring previous ‘/usr/local/lib/R/site-library/caTools’
* installing *source* package ‘edgeR’ ...
** using staged installation
** libs

Error: package ‘Rcpp’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘edgeR’
* removing ‘/usr/local/lib/R/site-library/edgeR’
* restoring previous ‘/usr/local/lib/R/site-library/edgeR’
* installing *source* package ‘GenomeInfoDb’ ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘RCurl’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘GenomeInfoDb’
* removing ‘/usr/local/lib/R/site-library/GenomeInfoDb’
* restoring previous ‘/usr/local/lib/R/site-library/GenomeInfoDb’
* installing *source* package ‘latticeExtra’ ...
** package ‘latticeExtra’ successfully unpacked and MD5 sums checked
** using staged installation
** R
** data
*** moving datasets to lazyload DB
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘RColorBrewer’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘latticeExtra’
* removing ‘/usr/local/lib/R/site-library/latticeExtra’
* restoring previous ‘/usr/local/lib/R/site-library/latticeExtra’
* installing *source* package ‘annotate’ ...
** using staged installation
** R
** data
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘AnnotationDbi’ 1.26.1 was found, but >= 1.27.5 is required by ‘annotate’
Execution halted
ERROR: lazy loading failed for package ‘annotate’
* removing ‘/usr/local/lib/R/site-library/annotate’
* restoring previous ‘/usr/local/lib/R/site-library/annotate’
* installing *source* package ‘GenomicRanges’ ...
** using staged installation
** libs

Error: package ‘GenomeInfoDb’ 1.0.2 was found, but >= 1.15.2 is required by ‘GenomicRanges’
In addition: Warning message:
version 1.24.0 of ‘GenomeInfoDb’ masked by 1.0.2 in /usr/local/lib/R/site-library 
Execution halted
ERROR: lazy loading failed for package ‘GenomicRanges’
* removing ‘/usr/local/lib/R/site-library/GenomicRanges’
* restoring previous ‘/usr/local/lib/R/site-library/GenomicRanges’
* installing *source* package ‘hgu95av2cdf’ ...
** using staged installation
** R
** data
** byte-compile and prepare package for lazy loading
Error: package ‘AnnotationDbi’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘hgu95av2cdf’
* removing ‘/usr/local/lib/R/site-library/hgu95av2cdf’
* restoring previous ‘/usr/local/lib/R/site-library/hgu95av2cdf’
* installing *source* package ‘org.Hs.eg.db’ ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘AnnotationDbi’ 1.26.1 was found, but >= 1.49.2 is required by ‘org.Hs.eg.db’
Execution halted
ERROR: lazy loading failed for package ‘org.Hs.eg.db’
* removing ‘/usr/local/lib/R/site-library/org.Hs.eg.db’
* restoring previous ‘/usr/local/lib/R/site-library/org.Hs.eg.db’
* installing *source* package ‘genefilter’ ...
** using staged installation
** libs

Error: package ‘annotate’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘genefilter’
* removing ‘/usr/local/lib/R/site-library/genefilter’
* restoring previous ‘/usr/local/lib/R/site-library/genefilter’
* installing *source* package ‘hgu95av2.db’ ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘AnnotationDbi’ 1.26.1 was found, but >= 1.34.3 is required by ‘hgu95av2.db’
Execution halted
ERROR: lazy loading failed for package ‘hgu95av2.db’
* removing ‘/usr/local/lib/R/site-library/hgu95av2.db’
* restoring previous ‘/usr/local/lib/R/site-library/hgu95av2.db’
* installing *source* package ‘simpleaffy’ ...
** using staged installation
** libs

Error: package or namespace load failed for ‘genefilter’:
 package ‘genefilter’ was installed before R 4.0.0: please re-install it
Error: package ‘genefilter’ could not be loaded
Execution halted
ERROR: lazy loading failed for package ‘simpleaffy’
* removing ‘/usr/local/lib/R/site-library/simpleaffy’
* restoring previous ‘/usr/local/lib/R/site-library/simpleaffy’
* installing *source* package ‘affyQCReport’ ...
** using staged installation
** R
** inst
** byte-compile and prepare package for lazy loading
Error: package ‘genefilter’ was installed before R 4.0.0: please re-install it
Execution halted
ERROR: lazy loading failed for package ‘affyQCReport’
* removing ‘/usr/local/lib/R/site-library/affyQCReport’
* restoring previous ‘/usr/local/lib/R/site-library/affyQCReport’

The downloaded source packages are in
    ‘/tmp/RtmpMfSFI0/downloaded_packages’
There were 15 warnings (use warnings() to see them)

Warning messages:
1: In install.packages(...) :
  installation of package ‘geneplotter’ had non-zero exit status
2: In install.packages(...) :
  installation of package ‘DESeq’ had non-zero exit status
3: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘AnnotationDbi’ had non-zero exit status
4: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘caTools’ had non-zero exit status
5: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘edgeR’ had non-zero exit status
6: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘GenomeInfoDb’ had non-zero exit status
7: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘latticeExtra’ had non-zero exit status
8: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘annotate’ had non-zero exit status
9: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘GenomicRanges’ had non-zero exit status
10: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘hgu95av2cdf’ had non-zero exit status
11: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘org.Hs.eg.db’ had non-zero exit status
12: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘genefilter’ had non-zero exit status
13: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘hgu95av2.db’ had non-zero exit status
14: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘simpleaffy’ had non-zero exit status
15: In install.packages(update[instlib == l, "Package"], l,  ... :
  installation of package ‘affyQCReport’ had non-zero exit status

I read about similar problems but i couldn t find a solution for these. I don t have too much experience so i really appreciate your colaboration.

package rna-seq deseq2 warnings R • 594 views
ADD COMMENTlink written 5 months ago by matiasbmg0

R v.4.0 is a really new release and many packages have likely not been built for it yet. Perhaps you should downgrade to last 3.x R and things will go more smoothly. DESeq2 will work fine with a slightly older R.

ADD REPLYlink modified 5 months ago • written 5 months ago by genomax91k
1

Note that with the first command you are installing DESeq not DESeq2

ADD REPLYlink written 5 months ago by ATpoint40k
1

...and I think that DESeq is now deprecated.

ADD REPLYlink written 5 months ago by Kevin Blighe66k

Yes, I made a mistake when I was writing the question. But I have the same warnings when I try to install DESeq2.

ADD REPLYlink written 5 months ago by matiasbmg0

I think that it is a matter of going through each error message, one by one, starting with this:

Error: package or namespace load failed for ‘AnnotationDbi’:

So, try to re-install this AnnotationDbi package, and then move to the next error. It may help, in fact, to simple load a fresh R session (never use the same session across multiple projects) and simply run:

BiocManager::install()

Then, update all packages when prompted.

You should be using R 4.0.0

ADD REPLYlink written 5 months ago by Kevin Blighe66k

I had a 3.4 version but I was having a similar problem so I decided to upgrade.

ADD REPLYlink written 5 months ago by matiasbmg0
4
gravatar for cpad0112
5 months ago by
cpad011214k
India
cpad011214k wrote:

Try to recompile all the packages as R 4.0 may need recompiling existing libraries. Start a fresh R session, and install bioconductor:

if (!requireNamespace("BiocManager", quietly = TRUE))
    install.packages("BiocManager")

Then recompile all the existing packages (takes lots of time):

pkgs <- rownames(installed.packages())
BiocManager::install(pkgs, type = "source", checkBuilt = TRUE)

Then install DESeq2

ADD COMMENTlink modified 5 months ago • written 5 months ago by cpad011214k

It works. Thank you very much!!!

ADD REPLYlink written 5 months ago by matiasbmg0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 995 users visited in the last hour