Cannot Install Latest Version Of Deseq
5
2
Entering edit mode
12.8 years ago
Pasta ★ 1.3k

Hi,

I am using R 2.12.1 and I would like to use the new function estimateDispersions() of from DESeq package 1.4.1.

The problem I am facing is that I am running the version 1.2.1 of DESeq but cannot update to the last version ... Typically, to update I use:

source("http://bioconductor.org/biocLite.R")
biocLite("DESeq")

but that doesnt work ... I read somewhere that I need r-dev to make it work, it is installed but that doesnt change a thing.

Any help is appreciated. Thanks

sessionInfo()

R version 2.12.1 (2010-12-16)
Platform: x86_64-pc-linux-gnu (64-bit)

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=C              LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] DESeq_1.2.1     locfit_1.5-6    lattice_0.19-13 akima_0.5-4    
[5] Biobase_2.10.0 

loaded via a namespace (and not attached):
 [1] annotate_1.28.1      AnnotationDbi_1.12.1 DBI_0.2-5           
 [4] genefilter_1.32.0    geneplotter_1.28.0   grid_2.12.1         
 [7] RColorBrewer_1.0-5   RSQLite_0.9-4        splines_2.12.1      
[10] survival_2.36-2      tools_2.12.1         xtable_1.5-6

EDIT: I tried to manually install DESeq 1.4.1 but I get this error:

Error : package 'Biobase' 2.10.0 was found, but >= 2.13.6 is required by 'DESeq'
ERROR: lazy loading failed for package ‘DESeq’

but I cannot find BioBase 2.13.6 anywhere :(

r deseq • 8.6k views
ADD COMMENT
0
Entering edit mode

Please also post the error message you get when trying to install DESeq 1.4.1 and the OS you are running.

ADD REPLY
0
Entering edit mode

@Michael: I am running Ubuntu 11.04. I do no get any error message when I install DESeq as it installs OK but not the latest version...

ADD REPLY
0
Entering edit mode

@Michael: I am running Ubuntu 11.04. I do no get any error message when I install DESeq, it just doesnt install the latest version

ADD REPLY
4
Entering edit mode
12.8 years ago
Ning-Yi Shao ▴ 390

Now the latest Biobase is 2.13.7.

And I think you should install R 2.14, and use bioclite to install the package.

Ref

ADD COMMENT
4
Entering edit mode
12.8 years ago
Michael 54k

You can't do it that way, you have to update your R installation to the latest version (atm 2.13.1, or devel version 2.14) to be able to install the latest version of Bioconductor. The Bioconductor versions are tightly linked with the R version. Manually installing single bioconductor packages on top of an older R version almost never works because of version requirements not met with other packages.

If you always need the newest BioC packages, one possible way is to regularly build the latest R version yourself from source. Unfortunately, none of the Linux distributions I know can keep pace with the R version updates for their compiled R binaries.

Much less hassle for you: use the Ubuntu repositories of cran to install the latest binary version using your package manager, follow the instructions here.

In short (for your ubuntu version 11.04 Natty), add a line to /etc/apt/sources.list file

deb http://<my.favorite.cran.mirror>/bin/linux/ubuntu natty/

Then run apt-get to install the latest R:

sudo apt-get update
sudo apt-get install r-base

Then, from inside R, install Bioconductor packages using biocLite as you did before.

ADD COMMENT
0
Entering edit mode

Thanks a lot - works like a charm !

ADD REPLY
2
Entering edit mode
12.8 years ago
Ryan Dale 5.0k

I read somewhere that I need r-dev to make it work, it is installed but that doesnt change a thing

It's kind of confusing, but Ubuntu's r-dev is the "developer's package" which contains the source code that you can use to compile the version Ubuntu ships (R 2.12.1).

For the latest DESeq (1.5.1+, with the new estimateDispersions and GLM framework) you need BioConductor 2.9, which depends on the development version of R, 2.14 . . . which isn't available in any Ubuntu repos that I know of (including the CRAN mirror repos which currently go up to R 2.13.1).

So you'll need to compile R 2.14 yourself. Once that's done, make sure you start up your new version of R, and then from in there the following should work:

source("http://bioconductor.org/biocLite.R")
biocLite("DESeq")
ADD COMMENT
1
Entering edit mode
12.8 years ago
Darked89 4.6k

Not sure if this is your case, but mixing Ubuntu/Debian packages installed by apt-get with R packages installed directly from CRAN may cause problems. If you must have the latest versions you may need to have your own (user version) R/Bioconductor versions and update any package as required.

ADD COMMENT
0
Entering edit mode
12.5 years ago
Dado • 0

After installing Ubuntu oneiric server and R 2.14 (using apt-get) I still get this error when trying to install DESeq!

package 'DESeq' is not available for R version 2.14.0

the installer is using R version 2.14.0 and biocinstall version 2.5.10 and tries to install Bioconductor 2.5 packages for some odd reason.

Any idea how to fix this?

Cheers,

Dado

ADD COMMENT
0
Entering edit mode

You can install DESeq via Bioconda using this command

conda install bioconductor-deseq2
ADD REPLY
0
Entering edit mode

This is a 7 year old post :-)

ADD REPLY

Login before adding your answer.

Traffic: 2088 users visited in the last hour
Help About
FAQ
Access RSS
API
Stats

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Powered by the version 2.3.6