Forum: Biostar 2.0, Second Beta, Help Us Test The New Site
2
gravatar for Istvan Albert
3.5 years ago by
Istvan Albert ♦♦ 73k
University Park, USA
Istvan Albert ♦♦ 73k wrote:

The second beta of Biostar is now live.

http://test.biostars.org/

Please visit and explore the site, post test questions, comments, moderate posts etc. All content will be replaced once the switch takes place so feel free to explore at will.

We are collecting feedback, opinions, bug reports, suggestions in this thread.

The goal is to switch to the new codebase in the near future.

forum biostar • 3.2k views
ADD COMMENTlink modified 3.4 years ago by Prakki Rama2.0k • written 3.5 years ago by Istvan Albert ♦♦ 73k
2
gravatar for SES
3.5 years ago by
SES7.9k
Vancouver, BC
SES7.9k wrote:

There are two issues that I see in one of my most recent posts.

  1. Gists are not being displayed correctly.

  2. Script names (with extensions like ".pl") are being turned into hyperlinks for some reason, which leads to nowhere.

Here is a post demonstrating both of these issues: About Percent_Identity And Bio::Searchio

Both of these issues may be handled correctly with new posts, I have not checked yet. This is just something I am seeing with posts from the current site.

ADD COMMENTlink modified 3.5 years ago • written 3.5 years ago by SES7.9k

what a strange bug, it comes from an external library, technically it could be a url for poland ...

the gist embedding is not yet finished

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k

I cleaned this up embedding should work as before

How To Plot Heatmap With Multiple Categories In A Single Cell With Ggplot2?

I have also fixed the perl extensions being turned into links, once I load the new data dump up it will be gone.

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k

This is only going to get worse with all the new gTLDs.

ADD REPLYlink written 3.5 years ago by Matt Shirley7.8k

yes indeed, it is now fixed, the text must start with http/ftp for it to be considered a link

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k
1
gravatar for Alex Reynolds
3.5 years ago by
Alex Reynolds20k
Seattle, WA USA
Alex Reynolds20k wrote:

I don't know if this is high on the list of design priorities, but it does not render usably on iOS devices. Elements are cut off and it is necessary to scroll from left to right to view all elements.

ADD COMMENTlink written 3.5 years ago by Alex Reynolds20k
1

It is actually a priority and there are many responsive elements built into the view already. It should display much better.

I forgot to check recently after I put in some layout changes and it looks that the width is not wrapped properly. This is difficult to test offline.

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k

If you have an OS X machine handy, it might help to sign up for a free Apple Developer account and grab the iOS dev toolkit, which includes iPad and iPhone simulators (the Safari browser is included in the simulator).

You do not need to spend $99 a year if you're only running apps or the simulator on your (desktop) computer, so this is a useful and free toolkit for testing web sites on mobile devices.

ADD REPLYlink modified 3.5 years ago • written 3.5 years ago by Alex Reynolds20k

I have made the changes and the site should look much better. Some posts are still too wide but that is almost always due to some content being to wide. I am not sure if I should just hide the parts that run out of window, could make things worse.

Find a post with lots of text like Computing Normalized Counts For Exons In Edger and should form a nice column. Also the navbar should collapse handily.

The way I test is a browser re-sizer like this: http://lab.maltewassermann.com/viewport-resizer/ it can produce viewport sizes for most devices.

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k
1
gravatar for Chris Miller
3.5 years ago by
Chris Miller18k
Washington University in St. Louis, MO
Chris Miller18k wrote:

I like many elements of the new design - it's a little cleaner.

A few bug reports:

  • The option to accept an answer should probably only appear if you are the person that asked the question.

  • If I move an answer with a code block in it to a comment on the top level post, the upvote logo and count for that comment elements overlap the code block. (see All Possible Substitutions In The Human Reference Genome)

  • The moderation comment auto-text could use some work. It seems like it would be good to visually make it clear which text was auto-filled, and which came from the moderator (rather than just sticking it in a PS block.

ADD COMMENTlink written 3.5 years ago by Chris Miller18k

good points, the code block overlap seems to happen always if the comment block is at the same level as the votebox. Looks like it has to to with margins and positioning. I may leave this as is, I just about had it fighting javascript and CSS on weekends.

One mitigating factor is that the content of the auto generated text can be edited by the moderator because it is a post created by them. It is a bit strange to write one line and get a whole post in its place. In a way I wish that the user did not know that the post was auto generated because that text tries to be polite and nice.

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k

Possible solutions: 1) give the moderator the whole blurb of text up front and let them edit as they see fit (I think the template for a polite response is a good idea). 2) insert an intermediate step between the moderation form and posting, where the moderator can edit the auto-generated text block. 3) Include a polite note in a div with a slightly different color/font (think blockquote here) and let the moderator add text below it (thus preserving the separation between auto-text and my words).

ADD REPLYlink written 3.5 years ago by Chris Miller18k
1
gravatar for Michael Dondrup
3.5 years ago by
Bergen, Norway
Michael Dondrup43k wrote:

Issues:

  • Bookmarking yields one upvote
  • Can't accept own answer to own question
  • CKeditor ;)
  • CKeditor: entering source code is very tedious, because editor goes out of 'formatted' mode with each line break. Inserts < p > which then needs to be deleted.
  • Session handling of test.biostars interferes with main site (need to change cookie name?)
  • When clicking 'moderate' after session expired, the interface doesn't display correctly after re-login.
  • Search finds deleted posts, when clicking on result shows wrong post: example search for "how to troll this forum best", click on top hit

  • no down-votes ;)

ADD COMMENTlink modified 3.5 years ago • written 3.5 years ago by Michael Dondrup43k

Great reports Michael, we will get to them one by one.

On CKEditor the situation may not be that grave, once you know what it does. It tries to preserve whatever actual formatting the source had to begin with. If you paste a text directly from a text file then it will not insert the p tags. Moreover if you insert from a web source that has a mime type of text (for example a github raw file) it will even recognize that in insert it directly as formatted text. An example is here, I did not have to touch any of it by hand other than highlight and set formatted on the upper text block. The lower block was inserted from a raw github output directly:

C: Extract Features From Gbk Via Bash

The problem occurs when inserting from another webpage, then it will attempt to maintain the original formatting.

I will look into turning that off. We'll fix the other issues soon.

ADD REPLYlink modified 3.5 years ago • written 3.5 years ago by Istvan Albert ♦♦ 73k
1
gravatar for Lluís R.
3.5 years ago by
Lluís R.550
Spain, Barcelona
Lluís R.550 wrote:

Well, I think that Biostars come from a StackExchange community, but here I miss the moderation tools and the Privileges system. I mean, I would love to improve the site improving some titles, adapting some formats, or just flagging as not related with the site and redirect to the right StackExchange page, or wherever it would make sense. Is there the possibility to add it? Although I find great to be able to run ads in the page from the community!

Another point I find that could be improved is the search engine, google works great, but sometimes it would be better to be able to search by the tag system. Again I found good the StackExchange system (Although sometimes it balances too much the upvotes and not the meaning or the content of the question.).

I also notice that the logo of the website that appears in the top of the Tab has changed. Is that permanent or it is just for the test version? Nice change, maybe it is time also to clean a little the site?

Thanks for your time!

ADD COMMENTlink written 3.5 years ago by Lluís R.550
1

We now have different levels of trust for users for the exact reason that you list. Basically the ability to become a moderator will be awarded based on a level contributions. This is not turned on yet because I want to make sure the core functionality works first.

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k

Sorry for the late reply. But where can I find this explained? When I gain enough reputation to edit others questions and answers? Where can I filter search by tags?

ADD REPLYlink written 3.4 years ago by Lluís R.550

The process is not automatic yet but every few months we look at who is active and seems to enjoy the process and give them moderator rights. You can see all moderators on the FAQ page:

https://www.biostars.org/info/faq/

To filter for tags just click the tag, you can also manually add multiple tags in the url like so:

https://www.biostars.org/t/R+sequencing/

ADD REPLYlink written 3.4 years ago by Istvan Albert ♦♦ 73k

The faq page doesn't explain which is the "certain reputation threshold" or which are the "moderation rights".

And if i do like the this it is I get post with one or the other tag but if I want just the post with both tags how I can do it?

I would find easier to be able directly to search with tags like in StackOverflow with "[R] OR [sequencing]" to get the same results as your link or "[R][sequencing]" To get just post with both tags.

ADD REPLYlink written 3.4 years ago by Lluís R.550

I have added more information on moderation rights to the FAQ: Moderators are able to edit or delete posts, move a post from a comment to an answer, and they are able to suspend or re-instate users. 

We are open to the idea of adding more search features, but people need to propose these first. 

ADD REPLYlink written 3.4 years ago by Istvan Albert ♦♦ 73k
1
gravatar for Devon Ryan
3.5 years ago by
Devon Ryan70k
Freiburg, Germany
Devon Ryan70k wrote:

One issue that seems to be the case on both the beta and the current version is that deleting an answer doesn't decrement the count of answers listed on the front page (e.g., A: How To Download Atomic Coordinates For A Specific Chain From A Pdb File? is listed as having 29 answers, even though it only has 7). This seems to be the case regardless of whether an answer is deleted by a moderator or by the original poster. Given the propensity of new users to "update their questions" by adding answers (which likely decreases further views since it looks like the question has already been answered), it would be nice if this were not the case. Thankfully moving an answer to a comment does decrement things appropriately.

Very minor issue: If you try to close a post without commenting you get a strange "• __ all__" error message above the expected "Unable to close. Please add a comment!" message.

ADD COMMENTlink written 3.5 years ago by Devon Ryan70k
1

good catch, this has now been fixed as with the other bug reports here.

I will put the site through another round of internal testing then make it live perhaps over the weekend.

ADD REPLYlink written 3.5 years ago by Istvan Albert ♦♦ 73k
0
gravatar for Lluís R.
3.4 years ago by
Lluís R.550
Spain, Barcelona
Lluís R.550 wrote:

I just found that if I previously logged in with the Open ID option. Now in the new version I need to say that I forgot the password and then get one for Biostars. Probably a explanation somewhere would be helpful.

ADD COMMENTlink written 3.4 years ago by Lluís R.550

There is a post for this here:

Biostar 2.0 released

send email to admin@biostars.org with the account that you want deleted, and when that is done you can merge the social login.

ADD REPLYlink written 3.4 years ago by Istvan Albert ♦♦ 73k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 2.3.0
Traffic: 751 users visited in the last hour